summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-04-22 21:45:45 +0800
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-06 13:46:26 +0200
commit2c299b338a224f193813b736a6c2580dc6f6afc5 (patch)
tree0c23dea86ceb1bf1114ccce46d8398873898e97e
parent81743c54a394df9fd81d9525bfe0fff63e849502 (diff)
gnu: retroarch: Fix OpenGL core and Vulkan drivers.
* gnu/packages/emulators.scm (retroarch)[arguments]: Ignore check result for HAVE_GLSLANG_HLSL in the configure phase. Change-Id: I3ba110b834acca25ada0e680a6bcb879b4db96f4 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emulators.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 3695311c87..84441181c7 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1520,6 +1520,10 @@ as RetroArch.")
(("/usr/local/share/wayland-protocols")
(string-append wayland-protocols "/share/wayland-protocols")))
+ ;; Without HLSL, we can still enable GLSLANG and Vulkan support.
+ (substitute* "qb/config.libs.sh"
+ (("[$]HAVE_GLSLANG_HLSL") "notcare"))
+
;; The configure script does not yet accept the extra arguments
;; (like ‘CONFIG_SHELL=’) passed by the default configure phase.
(invoke