summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2024-04-30 11:54:08 -0600
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-14 12:39:36 +0100
commit3c59a78345ee0c65dc024e481fad63606a62d17b (patch)
tree2c6d8c287da833887d72f2a0f803520f36ad74ac
parent393f496a0ac25e9717f93d7c0882d45a19b41460 (diff)
gnu: go-1.22: Disable flakey tests.go-team
* gnu/packages/golang.scm (go-1.22): Disable flakey tests. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Iae54b66ca9e330a8a6fafdba23869fccf875aab4
-rw-r--r--gnu/packages/golang.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b4ea1c83e1..3a1233d79f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2018, 2019, 2020, 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
+;;; Copyright © 2018, 2019, 2020, 2023, 2024 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2019 Giovanni Biscuolo <g@xelera.eu>
;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019, 2020, 2021 Arun Isaac <arunisaac@systemreboot.net>
@@ -972,7 +972,13 @@ in the style of communicating sequential processes (@dfn{CSP}).")
;; to perl input in sourcecode generators and test scripts
(substitute* (find-files "src" "\\.pl$")
(("^#!.*")
- "#!/usr/bin/env perl\n"))))))))
+ "#!/usr/bin/env perl\n"))))
+ (add-after 'unpack 'remove-flakey-thread-sanitizer-tests
+ (lambda _
+ ;; These tests have been identified as flakey:
+ ;; https://github.com/golang/go/issues/66427
+ (substitute* "src/cmd/cgo/internal/testsanitizers/tsan_test.go"
+ ((".*tsan1[34].*") ""))))))))
(native-inputs
;; Go 1.22 and later requires Go 1.20 (min. 1.20.6, which we don't have)
;; as the bootstrap toolchain.