summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-05-18 21:48:14 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-05-19 10:45:52 +0200
commitc09e187c78f0e705ed773341b816e45435b85afe (patch)
tree82fd4d3486fb505a7e5d5194aadc78e24f12c49f
parent147b3be38a0e89853f95dfb8b82dc8bf63e937d2 (diff)
gnu: gnome-builder: Fix build.gnome-team
* gnu/packages/gnome.scm (gnome-builder)[#:phases]: Add ‘patch-source’.
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0023a7123f..5ad34f5cc5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -13403,6 +13403,14 @@ libraries. Applications do not need to be recompiled--or even restarted.")
#:configure-flags #~(list "-Dnetwork_tests=false" "-Ddocs=true")
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ ;; With Gnome 4.14, GtkStackPage has an autoptr already, so it'd
+ ;; get redefined. Drop this phase when updating gnome-builder to
+ ;; 46.0 or newer. See also
+ ;; <https://gitlab.gnome.org/GNOME/gnome-builder/-/commit/7aaaecefc2ea8a37eaeae8b4d726d119d4eb8fa3>
+ (substitute* "src/libide/tweaks/ide-tweaks-window.c"
+ (("G_DEFINE_AUTOPTR_CLEANUP_FUNC \\(GtkStackPage, .*\\)") ""))))
(add-after 'unpack 'patch-meson
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "meson.build"